FANDOM


  • I was really exited to know the spore servers are back up. However, when i logged in, something seriously wrong happened. The game worked as it was supposed too, but the sporepedia was white and the creation cards were just blank white cubes with the creation in the middle. If you aim your mouse right on these cubes, you can open up a large viewer. Then everything works. The Sporepedia itself is a huge white cub with an invisible exit button. This same problem happens with the login screen, and the editor. Not to mention that the buttons are white cubes too. I have windows 10 installed, and i use Galactic Adventures. Can spore even run on Windows 10? is Windows 10 the problem? Please help.

    UPDATE: This problem has been solved almost a year ago, now we have server issues. Scroll up in the forum. I believe the issue was that I was using the Disc version. I called an EA employee and he let me use my codes to get Spore/GA/C&C on Origin. Everything is fine now.

      Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.